<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":3,"applicationTime":234,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-83305404-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<script src="https://cdn.rivals.com/production/packs/js/application-470fcb83c674e4c58e70.js"></script>
<link rel="stylesheet" media="screen" href="https://cdn.rivals.com/production/packs/css/application-f351f94b.css" />
<title>BadgerBlitz  -  OL Sean Timmis is first preferred walk-on commit for Badgers in 2020</title>
<meta content='BadgerBlitz  -  OL Sean Timmis is first preferred walk-on commit for Badgers in 2020' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-02eb9b5f2c94db113dfb318987ff62b83675833797c26696434b80eefa9d2109.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-ca9375cb00157a94fb9145cdc52b8a8b269ffbbc606ad5f3cc60aef1d1a15362.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="5JiING7v/7RapQFgwtcRO4FJH2m3guW+J5EaGtWg9CsmFw8DKlg0SOk18EgXeCl36N+GmkyM3HkTJIbemYBCCA==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      return {
        getPremiumIcon: getPremiumIcon
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020?yptr=yahoo?src=rss' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/siwueg7kkupjko1golxq' property='og:image'>
<meta content='Over 20 schools offered Sean Timmis a scholarship during the course of his recruitment. But a chance to stay close to...' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-06-27 15:50:44 -0500' property='article:published_time'>
<meta content='2019-06-27 16:15:06 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Sean Timmis' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "wisconsin.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='wisconsin contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .wisconsin #programming > h1 {
      background-color: #cc0000 !important; } }
  .wisconsin .wrapper-container .team-colors-line {
    background-color: #CFCFCF; }
  .wisconsin .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #cc0000; }
    .wisconsin .team-colors-line .color {
      width: 33.33%; }
    .wisconsin .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .wisconsin .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .wisconsin .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .wisconsin .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .wisconsin .team-colors-line.header {
      height: 6px; }
  .wisconsin > header .notification-link .count-container {
    background-color: #cc0000 !important; }
  .wisconsin > header .wrapper-container {
    background-color: #cc0000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .wisconsin > header .wrapper-container {
        border-bottom: 6px solid #CFCFCF !important; } }
  .wisconsin > header .invalid-email-banner {
    background-color: #cc0000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .wisconsin > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .wisconsin > header .invalid-email-banner a:hover {
      color: #CFCFCF; }
  @media screen and (max-width: 767px) {
    .wisconsin > header .mobile-header {
      background-color: #CFCFCF !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .wisconsin > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .wisconsin > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .wisconsin > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .wisconsin > header .nav-row > ul,
    .wisconsin > header .third-nav {
      background-color: white !important; }
    .wisconsin > header .dropdown-toggle > i.fa {
      color: #cc0000 !important; } }
  .wisconsin > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #cc0000; }
  
  .site-primary-font-color {
    color: #cc0000; }
  
  .site-primary-background-color {
    background-color: #cc0000; }
  
  .site-secondary-font-color {
    color: #CFCFCF; }
  
  .site-secondary-background-color {
    background-color: #CFCFCF; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(204, 0, 0, 0.4), rgba(204, 0, 0, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #cc0000;
    --secondary-color: #CFCFCF;
    --accent-color: #cc0000;
    --button-color: #cc0000; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false)' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Wisconsin" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://wisconsin.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/snvjtp2bdtyd3i07q9bw" alt="Snvjtp2bdtyd3i07q9bw" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://wisconsin.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;wisconsin&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://wisconsin.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;wisconsin&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733175,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "OL Sean Timmis is first preferred walk-on commit for Badgers in 2020"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='McNamaraRivals' name='twitter:site'>
<meta content='OL Sean Timmis is first preferred walk-on commit for Badgers in 2020' name='twitter:title'>
<meta content='Over 20 schools offered Sean Timmis a scholarship during the course of his recruitment. But a chance to stay close to...' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/siwueg7kkupjko1golxq' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":169,"legacy_id":907,"name":"BadgerBlitz","friendly_name":"Wisconsin","annual_discount":null,"subdomain":"wisconsin","primary_color":"cc0000","secondary_color":"CFCFCF","font_color":"ffffff","short_name":"Wisconsin","maple_ncaaf_team_id":36,"maple_ncaaf_endpoint":"ncaaf/teams/wwo","maple_ncaab_team_id":657,"maple_ncaab_endpoint":"ncaab/teams/wbg","maple_college_id":36,"google_analytics_id":"UA-83305404-1"}, true, 185, nil, {"id":141,"primary_color":"cc0000","secondary_color":"CFCFCF","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"BadgerBlitz.com","header_logo_cloudinary":"snvjtp2bdtyd3i07q9bw","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-83305404-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":true,"site_id":169,"created_at":"2016-11-23T13:38:44.836-06:00","updated_at":"2019-01-14T19:00:05.779-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://wisconsin.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000, false, {"id":144,"user_id":8482,"site_id":169,"updated_at":"2017-08-02T09:51:53.914-05:00","publisher_name":"Jon McNamara","first_name":"Jon","last_name":"McNamara","site_title":"Editor","bio":"Jon McNamara is a graduate of the University of Wisconsin-Madison. He has covered UW athletics since 2002 and has worked at Rivals.com since 2006. ","twitter_handle":"McNamaraRivals","image_url":"https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/izbcmceemg5riepsjwlz","publisher_name_and_title":"Jon McNamara, Editor","site_name":"BadgerBlitz","site_short_name":"Wisconsin","has_edited_profile":true})'>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>


<rv-message-boards ad-referer='https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020?yptr=yahoo?src=rss' base-api-url='https://Wisconsin.forums.rivals.com/' homepage='false' message-board-url='https://wisconsin.forums.rivals.com' pub-ad='null' size='size' space-id='2022733175' subscribed-user='subscribedUser'></rv-message-boards>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020/printable' site-name='BadgerBlitz'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-06-27 15:50:44 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2055771/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>OL Sean Timmis is first preferred walk-on commit for Badgers in 2020</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/izbcmceemg5riepsjwlz'>
<span>
<span class='author-name'>
Jon McNamara
&bull;
</span>
<span class='type-sm'>BadgerBlitz</span>
<div class='type-sm'>
<a href='//twitter.com/McNamaraRivals' target='_blank'>@McNamaraRivals</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Editor</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/McNamaraRivals'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
Jon McNamara is a graduate of the University of Wisconsin-Madison. He has covered UW athletics since 2002 and has worked at Rivals.com since 2006. 
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>Over 20 schools offered <a href="https://n.rivals.com/content/prospects/2020/sean-timmis-233541">Sean Timmis </a>a scholarship during the course of his recruitment. </p><p>But the chance to stay close to home and attend school at Wisconsin was too much for the in-state offensive lineman to pass on. Thursday, the 6-foot-5, 265-pound senior from Marquette University accepted a preferred walk-on offer from the Badgers, becoming the first walk-on commit for UW in the 2020 class.</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/siwueg7kkupjko1golxq','https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto/siwueg7kkupjko1golxq')">
<div class='blurred-image image-with-caption'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/siwueg7kkupjko1golxq)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/siwueg7kkupjko1golxq" alt="Siwueg7kkupjko1golxq" />
<div class='zoom-image'></div>
</div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Sean TImmis</figcaption>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/uv9uql29wsmvqsnba6es','https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto/uv9uql29wsmvqsnba6es')">
<div class='blurred-image'>
<a href='https://wisconsin.rivals.com/sign_up?promo_code=Summer19' target='_blank'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/uv9uql29wsmvqsnba6es)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/uv9uql29wsmvqsnba6es" alt="Uv9uql29wsmvqsnba6es" />
</a>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>"After all the camps were finished, Coach (Chris) Haering and I had a conversation and he told me I performed very well at camp and they loved my attitude," Timmis told BadgerBlitz.com. "But they already had five linemen committed, so he told me that I definitely had a preferred walk-on spot with them.</p><p>"I love that it’s close to home. I also have great relationships with Coach (Joe) Rudolph and Coach Haering. Also, if I set football aside, I would most likely be going to Wisconsin because it’s a great school with great people. Finally, I just love the way they play football."</p><p>Timmis, who attend UW's first camp of the summer on June 1, joins an impressive offensive line class for Wisconsin that also includes <a href="https://n.rivals.com/content/prospects/2020/jack-nelson-209429">Jack Nelson</a>, <a href="https://n.rivals.com/content/prospects/2020/trey-wedig-208705">Trey Wedig</a>, <a href="https://n.rivals.com/content/prospects/2020/dylan-barrett-209168">Dylan Barrett</a>, <a href="https://n.rivals.com/content/prospects/2020/ben-barten-225812">Ben Barten</a> and <a href="https://n.rivals.com/content/prospects/2020/tanor-bortolini-215356">Tanor Bortolini</a>. He is projected to play guard or center when he arrives on campus.</p><p>"I really just believed that Wisconsin was the best mix of a great education and great football," Timmis said. "I loved every visit I had there and I believed it would provide me with a great opportunity to excel in the classroom and prepare me for a career in the business world while being close to home.</p><p>"I really liked a lot of my Ivy League and Patriot League opportunities. I also was considering Temple, Northern Illinois and Buffalo."</p><p>In the 2020 class, the Badgers have also extended preferred walk-on offers to cornerback <a href="https://n.rivals.com/content/prospects/2020/amaun-williams-233532">Amaun Williams</a>, linebacker <a href="https://n.rivals.com/content/prospects/2020/ross-gengler-236607">Ross Gengler</a>, kicker <a href="https://n.rivals.com/content/prospects/2020/jack-van-dyke-234461">Jack Van Dyke</a> and long snapper <a href="https://n.rivals.com/content/prospects/2020/duncan-mckinley-256090">Duncan McKinley</a>. Timmis, who helped the Hilltoppers to a 12-1 record this past fall, is excited to put the recruiting process behind him in order to focus on his senior season. </p><p>"It’s a relief," he said. "I know I’m going to a place where I’ll be happy and my parents can come watch my games. I’m ready to focus on a huge senior season.</p><p>"The coaches were pumped when I committed. They told me they could not be more excited to have me and believe I have a real chance to earn playing time while getting a great education."</p><p><b>From Marquette head coach Jeffrey Mazurczak:</b></p><p><i>"Sean is a very intentional, fierce and strong run blocker who finishes very well. As a junior, he was just as good as <a href="https://n.rivals.com/content/prospects/2018/jon-gaines-211865">Jon Gaines</a>, who we sent to UCLA. Sean gives you everything physically, and along with that comes a package of leadership that will make him stand out on that roster."</i></p>
</div>
<div class='article-video'>
<iframe allowfullscreen='' frameborder='0' src='//www.hudl.com/embed/video/3/8220260/5bea18821600b113f8145adb'></iframe>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020/printable' site-name='BadgerBlitz'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":169,"legacy_id":907,"name":"BadgerBlitz","friendly_name":"Wisconsin","annual_discount":null,"subdomain":"wisconsin","primary_color":"cc0000","secondary_color":"CFCFCF","font_color":"ffffff","short_name":"Wisconsin","maple_ncaaf_team_id":36,"maple_ncaaf_endpoint":"ncaaf/teams/wwo","maple_ncaab_team_id":657,"maple_ncaab_endpoint":"ncaab/teams/wbg","maple_college_id":36,"google_analytics_id":"UA-83305404-1"}' twitter-feed='{"id":168,"site_id":169,"handle":"McNamaraRivals","list_name":"staff","created_at":"2016-02-01T12:25:38.632-06:00","updated_at":"2017-08-14T11:56:45.665-05:00","hashtags":[],"usernames":["McNamaraRivals","JohnVeldhuis"],"max_number":2}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020/printable' site-name='BadgerBlitz'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733175', 'https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020?yptr=yahoo?src=rss');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "OL Sean Timmis is first preferred walk-on commit for Badgers in 2020";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("Wisconsin", 2055771, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
</div>
</div>

</div>
</main>
<div data-react-class="Footer/container" data-react-props="{}"></div>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733175",
    c7: "https://wisconsin.rivals.com/news/ol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020?yptr=yahoo?src=rss"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fwisconsin.rivals.com%2Fnews%2Fol-sean-timmis-is-first-preferred-walk-on-commit-for-badgers-in-2020%3Fyptr%3Dyahoo%3Fsrc%3Drss&c5=2022733175&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
